A Formal Analysis of The Modified 5G EAP-TLS Protocol
Từ khóa
DOI:
https://doi.org/10.54654/isj.v2i28.6385Tóm tắt
Giao thức 5G EAP-TLS là một trong ba giao thức được 3GPP tiêu chuẩn hóa để sử dụng trong mạng 5G. Mặc dù giao thức này vốn đảm bảo tính bảo mật, xác thực và toàn vẹn dữ liệu, các nghiên cứu gần đây đã chỉ ra rằng nó vẫn phải đối mặt với một số lỗ hổng, bao gồm các cuộc tấn công Man-in-The-Middle, mạo danh người dùng và tấn công phát lại. Bài báo này trình bày mô tả chi tiết các bước trong giao thức EAP-TLS được sửa đổi, để giải quyết các vấn đề này bằng cách liên kết trực tiếp chứng chỉ số với định danh SUCI của người đăng ký để ngăn chặn mạo danh người dùng, liên kết khóa phiên với cả chứng chỉ và định danh để đảm bảo khả năng chống lại các cuộc tấn công xen giữa và giới thiệu giá trị nonce để ngăn chặn việc sử dụng lại các gói tin cũ trong các cuộc tấn công phát lại. Bài báo sử dụng công cụ Proverif như một phương pháp xác minh chính thức để đánh giá tính bảo mật của giao thức 5G EAP-TLS sửa đổi. Kết quả xác minh cho thấy giao thức được đề xuất đáp ứng các thuộc tính bảo mật đã được chỉ định, bao gồm tính bảo mật của khóa phiên (KSESSION), định danh người đăng ký (SUPI), the pre-master key (RPREKEY), cũng như các yêu cầu bảo mật liên quan khác.Lượt tải
Tài liệu tham khảo
GPP TS 33.501 version 18.10.0 Release 18, "TS 133 501 - V18.10.0 - 5G; Security architecture and procedures for 5G System".
J. P. Mattsson and M. Sethi, "EAP-TLS 1.3: Using the Extensible Authentication Protocol with TLS 1.3", Internet Engineering Task Force, Request for Comments RFC 9190, 2022. DOI: 10.17487/RFC9190.
E. Rescorla, "The Transport Layer Security (TLS) Protocol Version 1.3", Internet Engineering Task Force, Request for Comments RFC 8446, 2018. DOI: 10.17487/RFC8446.
G. A. Tuan, N. H. Ha, D. N. Quang, L. H. Ton, and T. T. Hieu, "Weak Links in Smart Surveillance: An Empirical Security Evaluation of Evil Twin Attacks on IoT Cameras", Journal of Science and Technology on Information security, no. 3, vol. 26, pp. 62–69, 2025, DOI: 10.54654/isj.v3i26.1163.
D. Simon, R. Hurst, and B. D. Aboba, "The EAP-TLS Authentication Protocol", Internet Engineering Task Force, Request for Comments RFC 5216, 2008. DOI: 10.17487/RFC5216.
D. Basin, J. Dreier, L. Hirschi, S. Radomirović, R. Sasse, and V. Stettler, "A Formal Analysis of 5G Authentication", Proceedings of the 2018 ACM SIGSAC Conference on Computer and Communications Security, pp. 1383–1396, 2018. DOI: 10.1145/3243734.3243846.
J. Zhang, L. Yang, W. Cao, and Q. Wang, "Formal Analysis of 5G EAP-TLS Authentication Protocol Using Proverif", IEEE Access, vol. 8, pp. 23674–23688, 2020, DOI: 10.1109/ACCESS.2020.2969474.
N. Zhu, J. Xu, and B. Cui, "Formal Analysis of 5G EAP-TLS 1.3", Advances in Internet, Data & Web Technologies, vol. 193, L. Barolli, Ed., in Lecture Notes on Data Engineering and Communications Technologies, vol. 193. , Cham: Springer Nature Switzerland, pp. 140–151, 2024. DOI: 10.1007/978-3-031-53555-0_14.
M. Shi, J. Chen, Z. Ma, K. He, M. Jia, and R. Du, "A Formal Analysis of 5G EAP-TLS Protocol", IEEE Trans. Netw., vol. 33, no. 5, pp. 2179–2191, 2025, DOI: 10.1109/TON.2025.3556374.
B. Blanchet, "Modeling and Verifying Security Protocols with the Applied Pi Calculus and ProVerif", Foundations and Trends® in Privacy and Security, vol. 1, no. 1–2, pp. 1–135, Oct. 2016, DOI: 10.1561/3300000004.
B. Blanchet, "The Security Protocol Verifier ProVerif and its Horn Clause Resolution Algorithm", Electron. Proc. Theor. Comput. Sci., vol. 373, pp. 14–22, 2022, DOI: 10.4204/EPTCS.373.2.
B. Blanchet, B. Smyth, V. Cheval, and M. Sylvestre, "ProVerif 2.05: Automatic Cryptographic Protocol Verifier, User Manual and Tutorial", 2023.
C. J. F. Cremers, "Unbounded verification, falsification, and characterization of security protocols by pattern refinement", Proceedings of the 15th ACM conference on Computer and communications security, pp. 119–128, 2008. DOI: 10.1145/1455770.1455787.
L. V. Thinh, "Paradigms in Security Protocol Verification: A Multi-Tool Analysis’, Journal of Science and Technology on Information security, no. 3, vol 23, pp. 62–81, 2024, DOI: 10.54654/isj.v3i23.1059.
D. Dolev and A. Yao, ‘On the security of public key protocols", IEEE Transactions on Information Theory, vol. 29, no. 2, pp. 198–208, 1983, DOI: 10.1109/TIT.1983.1056650.